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Popis systému Delta V 
 
Viz též soubor DeltaV_uvod.doc. 
 

 
Pozn.: sekundární řídicí síť je záložní a tedy není nezbytně nutná 
 
Další informace lze získat z počítače pomocí knihovny Books Online, kterou vždy najdeme 
v položce Help jednotlivých programů nebo volbou Start > DeltaV > Help > Books Online. 
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Terminologie 
 

 
 
Obr.1 Terminologie a struktura programů systému DeltaV 
Pozn.: FBD = Function Block Diagram, SFC = Sequential Function Chart 
 
 
V následujícím textu vytvoříme moduly pro řízení systému pro řízení výtoku kapaliny 
z nádrže. Modul LI-101 (Level Indicator) monitoruje výšku hladiny v nádrži, modul MTR-101 
spouští a vypíná motor čerpadla, modul XV-101 ovládá dvoustavový ventil, a modul FIC-101 
reguluje výtok kapaliny. Vstupy do modulů jsou označeny LT-1, XI-1, LSC-1, FT-1 a výstupy 
z modulů jsou označeny ZX-1, XV-1, FT-1 – viz obr.2. 
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Obr.2 Příklad systému pro řízení výtoku kapaliny z nádrže 
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Seznámení s programem DeltaV Explorer 
(viz příručku Getting Started with your Delta Automation Software, od str.3-1) 
 
Pozn.: v dalším textu symbol ‘>‘označuje postup volby možností uvedených na obrazovce. 
Následující postupy doporučujeme provádět na cvičném počítači (není připojen na reálný 
systém). 
 
1. Otevření programu DeltaV Explorer 
Klikneme na  Start > All Programs > DeltaV > Engineering > DeltaV Explorer 
Otevře se okno: 
 

 
 

Obr.1  Okno programu DeltaV Explorer 
 
2. Knihovny (viz následující okno) 
Otevřeme Library > Function Block Templates 
Postupně vybereme jednotlivé knihovny od Advanced Control až po Timer Counter. 
Prohlédneme si jejich obsah a zavři Function Block Templates. 
 
3. Nastavení času 
 Klikneme na  Tools > Set/Synchronize Network Time 
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Obr.2 Okno s otevřenou knihovnou modulů Analog Control 
 
 
4. Vytvoření a pojmenování Plant Areas (oblasti, části podniku s řízeným systémem) 
Plant Areas jsou logické, programově vytvořené části řídicího systému, které mohou avšak 
nemusí odpovídat fyzickému rozdělení řízeného systému (továrny, podniku). Plant Areas 
obsahují moduly vytvářející zvolenou strategii řízení. 
DeltaV systém má implicitně zavedenu oblast AREA_A, kterou nelze smazat, protože je 
důležitá pro činnost programu a některých jeho funkcí. 
Vybereme Control Strategies > pravé tlačítko > New Area > pojmenujeme 
AREA101_vasejmeno (např. vasejmeno bude konkretně NOVAK) > stiskneme Enter 
 
Tlačítkem Minimize vpravo nahoře stáhneme DeltaV Explorer dolů na lištu. 
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Seznámení s programem Control Studio 
(viz příručku Getting Started with your Delta Automation Software, od str.4-5) 
Pozn.: v textu citujeme postupy pomocí menu, použití ikon necháváme na studentovi. 
 
Cvičení 1:   Otevření programu Control Studio a postupné vytvoření modulu XV-101  
(viz obr.6 volba Start from Existing - na rozdíl od cvičení 4, kde je volba Create New) 

 
Klikneme na  Start > All Programs > DeltaV > Engineering > Control Studio > po otevření 
okna programu klikneme na File > New > vyber Control Module or Template > vybereme 
Start from Existing > Browse > v poli Object Type vyber Module templates > dvojklik na 
Valves-Normally Closed > vybereme VLVNC-11 > OK > znovu OK. 
Otevře se následující okno: 
 

 
 

Obr.1 Okno programu Control Studio s otevřeným modulem ventilu 
 
 
 
Cvičení 2:    Modifikace modulu DC1 pro připojení vstupů a výstupů 
Vybereme blok DC1 > přejdeme myší na pole Parameter a klikneme pravým > vyber Filter 
Parametr List…> otevře se okno Parameter filtering, v němž zaškrtneme Common 
configuration a On-line > OK. 
V poli Parameter dvojklik na parametr IO_IN_1 > otevře se okno IO_IN_1 Properties (viz 
obr.3) > do pole Device Tag zapiš LSC-1 (v našem příkladu zkratka pro Limit Switch-Closed,  
což je označení informace o poloze ventilu) > v poli Parameter zvolíme  FIELD_VAL_D > 
OK.  
Viz obr.3. 
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Tyto dva parametry t.j.  LSC-1  a  FIELD_VAL_D   definují Device Signal Tag (DST).  
 
V poli Parameter dvojklik na IO_OUT_1 > jako předešle doplníme  XV-1 (v našem příkladu 
označení výstupu pro řízení ventilu) a zvol  OUT_D > OK. Výsledek je uveden na obr.4. 
 

 
 

Obr.2 Okno Parameter Filtering 
 

 
 

Obr.3 Okno pro zápis cesty k hardwaru (Device Signal Tag - DST) 
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Obr.4 Zapsané cesty k hardwaru (DST) 
 
 

Cvičení 3:   Ukončovací kroky platící pro všechny řídicí moduly 
 
a) Propojit tvořený řídicí modul s oknem operátora (viz dále) 
Vyberme File > Properties > Displays > do pole Primary Control napíšeme TANK101 (což je 
název okna operátora, které vytvoříme později pomocí DeltaV Operate) > OK. 
 
 
 

 
 

Obr.5 Propojení modulu s oknem operátora 
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b) Propojit modul s řadičem 
Vybereme File > Assign to Node > vybrat řadič podle názvu > OK. 
Název řadiče zadáváme programem DeltaV Explorer následujícím postupem 
Start > Engineering > DeltaV Explorer > pravým tlačítkem na Control Network > New > 
Controler > do místa označeného kurzorem napíšeme CTRL1_vasejmeno.  
Pozn.: cvičný počítač není připojen na řadič a proto naše možnosti v tomto směru jsou 
omezené. Na počítači s připojeným systémem je řadič nazván CTRL-00AE9C. Tam nic 
nesmíme měnit! 
 
c) Uložit modul 
Vybereme File > Save As > v poli Object Types vybereme Modules > do pole Object Name 
napíšeme XV-101_vasejmeno > v poli Look in vybereme Area101_vasejmeno > klikneme na 
Save. 
 
d) Ověřit konfiguraci modulu 
Vybereme File > Properties > Tools Verify Now > přečteme si hlášení, které upozorňuje u 
cvičného počítače na nepřítomnost řadiče. 
 
 
Cvičení 4:   Vytvoření modulu LI-101  (obr.6 s volbou Create New) 
Modul má měřit hladinu kapaliny v nádrži. Má jeden analogový vstup (LT-1) z čidla pro 
měření hladiny a jeden výstup, digitalizovaný parametr. 
Volíme File > New > objeví se následující okno > OK. 
 

 
Obr.6 Nastavení programu Control Studio pro vytvoření FBD 
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Z palety knihoven (zcela vpravo na obr.1) vyber IO, myší uchopíme funkční blok Analog 
Input a přetáhneme nalevo do pracovního okna.  
 
Klikneme na Analog Input pravým tlačítkem a vyber What´s this? > objeví se informace o 
tomto funkčním bloku. Detailní informaci získáme kliknutím na Reference (v okně vlevo 
dole). 
 
V seznamu parametrů (okno na obr.1 vlevo dole) dvojklik na parametr HI_HI_LIM > pole 
Properties přepíšeme na 1000 > OK. 
 
Dvojklik na parametr IO_IN > do pole Device Tag napiš LT-1 (level transmitter) > OK. 
 
Ověříme, zda parametr L_TYPE (linearization type) má nastavenu hodnotu Indirect. Je to 
nutné pro zachování možnosti definovat fyzikální jednotky vstupu. 
 
Pro nastavení fyzikálních jednotek provedeme dvojklik na parametr OUT_SCALE > pole 
100% scale přepíšeme na 10000 > v poli Engineering unit vybereme   liter > OK. 
 

 
 

Obr.7 Okno pro volbu fyzikálních jednotek 
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Z palety knihoven (obr.1 vpravo) vybereme Special Items > vybereme funkční blok Output 
parameter a přetáhneme jej do pracovního okna nalevo > objeví se okno Properties > 
změníme jméno parametru na PV (process value) > v poli Parameter type vyber Floating point 
> v poli Parameter category vybereme  I/O > OK > v pracovním okně se objeví funkční blok 
PV. 
 
Dále nastavíme sběr dat z tohoto funkčního bloku PV. 
Vyber funkční blok AI v pracovním okně > v okně parametrů klikni pravým tlačítkem na 
parametr PV > vyber Add History Recorder > objeví se okno Add History Collection > 
doplníme pole podle obr.8 > OK. 
 

 
 

Obr.8 Okno pro nastavení sběru dat 
 

Pozn.: v dalším programování lze oblast (AREA101_vasejmeno) připojit na subsystém 
Continuous History, který se zvolenou vzorkovací periodou (Sampling period) postupně sbírá 
data v oblasti pracovní stanice. 
 
Spojení obou funkčních bloků. 
Vybereme v menu (v okně podle obr.1) položku Diagram > Connect > kurzor se změní na 
tužku > stiskneme levé tlačítko a spojíme oba funkční bloky (ve správné pozici se kurzor 
změní na hvězdičku). 
 



Programování systému DeltaV 
 

13

 
Dokončení modulu LI-101 provedeme podle Cvičení 3. Modulu přiřadíme okno operátora 
(které vytvoříme později pomocí DeltaV Operate) nazvané TANK101, modulu přiřadíme řadič 
a uložíme modul do oblasti AREA101_vasejmeno pod názvem LI-101_vasejmeno. 
 
 
Cvičení 5:   Vytvoření PID regulátoru (modul FIC-101) 
Použijeme vzorek modulu z knihovny Analog Control prostřednictvím programu Delta 
Explorer. 
 
Otevřeme Delta Explorer (obr.1) > vyber Library > Module Templates > Analog Control > 
uchopíme PID_LOOP a přetáhneme do AREA101_vasejmeno > v této oblasti přejmenujeme 
na FIC-101_vasejmeno. 
 
Vyber FIC-101_vasejmeno > klikneme pravým tlačítkem > vyber Assign > v okně Browse 
vybereme řadič > OK.  
Pozn.: alternativně lze modul přetáhnout myší z oblasti na řadič. 
 
Dále upravíme parametry modulu. 
Otevřeme oblast AREA101_vasejmeno (obr.1 vlevo) > otevřeme FIC-101_vasejmeno > 
dvojklik na PID1 > otevře se následující okno (obr.9). 
 

 
 

Obr. 9 Okno pro editaci parametrů modulu PID1 
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Dvojklik na parametr IO_IN > otevře se okno IO_IN Properties > do pole Device Tag zapsat 
FT-1> OK. 
 
Dvojklik na IO_OUT > okno IO_OUT Properties > zapsat FY-1 > OK. 
 
Dvojklik na GAIN > změnit Value na 1 > OK. 
 
Dvojklik na RESET > změnit Value na 3 (opakování po 3 sekundách) > OK. 
 
Dvojklik na PV_SCALE  > změnit Engineering unit na liter (objem. jedn. litr) > OK. 
 
Dvojklik na CONTROL_OPTS > Direct acting nesmí být zaškrtnuto (modul tedy bude 
pracovat inverzně) > OK. 
 
Dvojklik na IO_OPTS (I/O options) > Increase to close nesmí být zaškrtnuto (zvětšení 
hodnoty otvírá ventil) > OK. 
 
 
Otevřeme modul FIC-101 pro další editaci v Control Studio. 
V DeltaV Exploreru vybereme modul FIC-101_vasejmeno > pravé tlačítko > vybrat Open 
with Control Studio > otevře se následující okno (obr.10) 
 

 
 

Obr.10 Okno otevřené na příkaz Open with Control Studio 
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Modifikace alarmu. 
Dvojklik na parametr HI_ALM (obr.10 dole) > změníme Limit value na 90 > OK. 
 
Dokončení modulu FIC-101 provedeme podle bodu 3. Modulu přiřadíme okno operátora 
(které vytvoříme později pomocí DeltaV Operate) nazvané TANK101, modulu přiřadíme řadič 
CTRL1_vasejmeno a uložíme modul do oblasti AREA101_vasejmeno pod názvem FIC-
101_vasejmeno. 
 
 
Cvičení 6:    Vytvoření modulu (MTR-101) zkopírováním předlohy 
Otevřeme program DeltaV Explorer. 
Klikneme na Library > Module Templates > Motors-2State > vyber MTR-11_ILOCK 
> uchopíme levým tlačítkem a přetáhneme do AREA101_vasejmeno > zde tento modul 
vybereme 
a klikneme pravym tlačítkem > Rename > pojmenujeme jej MTR101_vasejmeno. 
 
Otevřeme program Control Studio. 
Klikneme na File > Open > do pole Look in vyber Area101_vasejmeno > v okně se objeví 
seznam modulů uložených v uvedené oblasti > vyber modul MTR-101_vasejmeno > Open 
> zvětši okno na celou obrazovku > vpravo vyber knihovnu Logical. 
Kliknutím pravým tlačtkem na bloky knihovny a výběrem Whatś This získáme informaci o 
jednotlivých blocích knihovny. 
 
Vyjmeme přebytečné bloky. 
Ve schematu modulu vybereme myší bloky CND4 až CND8 > stiskneme Delete > potvrdíme 
kliknutím na Yes. 
 
Nastavíme podmínky činnosti bloků. 
V menu klikneme na Windows > Arrange Windows. 
Vybereme blok CND1 > klikni pravým a vybereme Expression > otevře se editační okno > 
označíme myší FALSE a smaž > klikneme na Insert External Parameter > otevře se okno 
Browse > dvojklik postupně na AREA101_vasejmeno > XV-101_vasejmeno > DC1 > PV_D > 
CV > informaci, která se objeví v okně, doplníme následujícím způsobem 
‘//XV-101_vasejmeno/DC1/PV_D.CV’=’vlvnc-pv:CLOSED’; 
 
XV-101_vasejmeno je modul ovládající dvoustavový ventil; DC1 je funkční blok; PV_D.CV je 
proměnná procesu; CLOSED je jeden ze stavů nastavení označeného vlvnc-pv. Napsaný výraz 
indikuje, že motor musí vypnout, je-li dvoustavový ventil uzavřen. Všechna možná nastavení 
(Named Sets) najdeme v DeltaV Exploreru proklikáním cesty System Configuration > Setup > 
Named Sets. 
 
Klikneme na tlačítko Parse. Správnost zápisu je ověřena > OK. 
 
Podobně postupujeme pro blok CND2. Zápis: ‘//LI-101_vasejmeno/AI1/PV.CV’ < 100; 
LU-101_vasejmeno je modul indikující výšku hladiny v nádrži, AI1 je blok analogového 
vstupu, PV.CV je parametr označující vstupní signál. Výraz udává, že motor má vypnout, je-li 
v nádrži méně než 100 litrů. 
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A rovněž pro blok CND3. Zápis: ‘//FIC-101_vasejmeno/PID1/PV.CV’ < 5; 
FIC-101_vasejmeno je modul řídící výstupní ventil, PID1 je odpovídající regulační smyčka, 
PV.CV je parametr označující okamžitou polohu výstupního ventilu. Výraz udává, že motor 
musí vypnout, je-li ventil otevřen méně než 5 procent. 
 
Dále definujeme DST pro modul MTR-101_vasejmeno. 
Ve schematu vybereme blok DC1 > v okně parametrů dvojklikneme na IO_IN_1 > do pole 
Device Tag zapíšeme XI-1 > v poli Parameter je FIELD_VAL_D > OK   
v okně parametrů dvojklikneme na IO_OUT_1 > do pole Device Tag zapíšeme ZX-1 > v poli 
Parameter je OUT_D. 
 
Dokončíme modul MTR-101_vasejmeno. 
V menu volíme File > Properties > Displays > okno podle obr.5 > do pole Primary Control 
napíšeme TANK101 > pole Detail (picture) změníme na DL_DT3.  
 
Připojíme modul na řadič File > Assign To Node…> vybereme CTRL1_vasejmeno. 
 
Modul uložíme volbou File > Save (modul již byl pojmenován). 
 
Minimalizujeme program Control Studio tlačítkem Minimize vpravo nahoře na obrazovce. 
 
 
 
Cvičení 7:  Vytvoření modulu sekvenčního algoritmu - SFC (Sequential Function Chart) 
Otevřeme DeltaV Explorer. 
Vybereme System Configuration > Setup > Named Sets. 
Klikneme pravým tlačítkem na Named Sets > objeví se nový Named Setn (kde n je nejnižší 
doposud nepoužité číslo) > název přepíšeme na SFCCTRL_vasejmeno > stiskneme ENTER. 
 
Dvojklik na  SFCCTRL_vasejmeno > Properties > do pole Description napíšeme Sequence 
Control > klikneme na Add > do pole Name napíšeme IDLE > OK > klikneme na Add > do 
pole Name napíšeme START > OK > výsledné okno je na obr.12 > OK. 
Minimalizujeme DeltaV Explorer.  
 
Nyní již můžeme vytvořit modul SFC. 
Otevřeme Control Studio > File > New > objeví se okno podle obr.6 > v poli Object type 
vybereme Control Module or Template > v poli Algorithm type vybereme Sequential Function 
Chart > OK > v okně Control Studio se objeví SFC diagram s jediným blokem kroku a to S1. 
 
Klikneme pravým tlačítkem do okna parametrů (vlevo dole) a z nabídky vybereme Add…> 
objeví se okno , které vyplníme podle obr.13 (do pole Parameter name napíšeme SP, do pole 
Parameter  type vybereme Named Set,  pole Named Set a Named State vyplníme pomocí 
Browse > vybrat SFCCTRL_vasejmeno > OK > vybrat IDLE > OK. 
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Obr.11 Okna pro vytvoření Named Set 
 
 

 
 

Obr.12 Vytvoření Named Set s názvem SFCCTRL_vasejmeno 
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Obr.13 Nastavení vlastností parametru 
 

V hlavním okně programu Control Studio vybereme blok S1. 
V okně Action (vpravo dole) klikneme pravým tlačítkem a vybereme Add…>  objeví se okno 
A1 Properties  > do okna Description napíšeme Stop and Wait > do pole Qualifier vybereme  
P Pulse (činnost kroku se provede jen při prvním spuštění a při dalších spuštěních se již nic 
nepřepisuje) > do pole Action expression napíšeme přes Expression Assistent výraz 
‘SP’:=’SFCCTRL_vasejmeno:IDLE’; (dodržet malá a velká písmena) – viz obr.14 > klikneme 
na Parse (kontrola výrazu) > OK > OK v okně Properties. 
 
V okně Action klikneme pravým tlačítkem na A1 > z nabídky vybereme Rename a změníme 
název na SET_TO_IDLE (tento název říká obsluze více než A1). 
V okně diagramu klikneme pravým tlačítkem na S1> vybereme Rename > přejmenujeme S1 
na STOP_AND_WAIT. 
 
V knihovně All SFC Items (vpravo) uchopíme Transition a přetáhneme do hlavního okna > 
objeví se + označené T1 > dvojklik na T1 > objeví se okno T1 Properties > do pole 
Description napíšeme Wait Until Start > přes Expression Assistant zapíšeme do pole 
Expression výraz  ‘SP’=’SFCCTRL_vasejmeno:START’ > klikneme na Parse > OK > v okně 
Properties klikneme na OK > v hlavním okně přejmenujeme T1 na WAIT_UNTIL_START. 
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Obr.14 Okno pro nastavení vlastností kroku SFC 
 
Nyní dokončíme SFC. 
Opakujeme předchozí procedury podle Tab.1. 
 
Propojíme bloky pomocí volby Graphics > Line > kurzor se změní na tužku (pokud se čára 
nepovedla, klikneme na ni dvakrát a stiskneme Delete). 
 
Volbou File > Properties > Displays  zapíšeme do pole Primary Control název okna 
operátora TANK101. 
 
Volbou File > Assign To Node… přiřadíme našemu SFC řadič CTRL1_vasejmeno  
(viz Cvičení 3 odst. b). 
 
Volbou File > Save As… uložíme modul pod názvem SFC-START_vasejmeno. 
 
Zavřeme Control Studio. 
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Tab.1 Postup pro dokončení SFC 
 

Poslední je uložení modulů do paměti řadiče.  
 
Otevřeme Delta Explorer > System Configuration > Physical Network > Control Network > 
CTRL1_vasejmeno > Assigned Modules > vypíše uložené moduly. 
 
Klikneme pravým tlačítkem na Control Network a vybereme Download > Control Network > 
objeví se postupně okna s informacemi o ukládání. 
 
 
Pozn.: v případě cvičného počítače řadič není připojen a program tedy vypíše příslušné 
hlášení. Tento postup si ověříme na počítači s připojeným systémem a s již nainstalovanými 
moduly za spolupráce s vyučujícím. 
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Seznámení s programem DeltaV Operate 
(viz příručku Getting Started with your Delta Automation Software, od str.5-7) 
 
Program DeltaV Operate slouží k vytváření oken podle nichž operátoři sledují a ovládají 
systém. Program pracuje ve dvou režimech:  
1.  Configure – slouží k vytváření obrázků. 
2.  Run – obrázky jsou aktivní, zobrazují aktuální data a umožňují řídit systém. 
 
Spuštění programu Delta Operate. 
Klikneme Start > All Programs > DeltaV > Operator > DeltaV Operate. 
 
DeltaV Operate se vždy otevře v režimu Run.  
Stiskem kláves Ctrl/W přepneme do režimu Configure. 
Název zvoleného režimu se objeví v názvu otevřeného okna. 
 
!!!! Klikneme na Picture > Templates > dvojklik na main > otevře se okno podle obr.15. 
 

  
 

Obr.15 Okno programu DeltaV Operate v režimu Configure s otevřenou šablonou main.grf 
 

 



Programování systému DeltaV 
 

22

 
Přečteme si informaci, kterou udává okno main.grf.  
Klikneme pravým tlačítkem na střed okna main.grf a z nabídky vybereme Delete > text z okna 
zmizí > klikneme na File > Save As > uložíme okno s názvem TANK101 do adresáře Pic. 
Pozn.: uložený soubor se objeví v levém okně v adresáři Picture. 
 
Seznámíme se s nabídkou Toolbars. 
Klikneme Workspace > Toolbars > objeví se okno, v němž musí být zaškrnuto Show Screen 
Tips on toolbars (obr.16).  
 
 

 
 

Obr.16 Okno pro volbu Toolbars 
 

Pro obě volby v poli Owner (WorkSpace, Picture) zaškrtneme všechny možnosti v poli 
Toolbars. Každá možnost se objeví v okně, prohlédneme si jej a zrušíme zaškrtnutí. 
 
Možnost úpravy Toolbars ověříme stiskem tlačítka Customize…, prakticky tuto možnost zatím 
nevyužijeme > klikneme na Close. 
 
Vybereme si DeltaV_Toolbox. Je to kombinace základních nástrojů pro vytváření obrázků 
(pracuje se s nimi běžným způsobem) > klikneme na  Close v okně Toolbars > objeví se okno 
DeltaV_Toolbar > umístíme kurzor na okraj okna DeltaV_Toolbar  a po změně kurzoru na 
oboustrannou šipku změníme jeho tvar > 
uchopíme opět okno Delta_Toolbar  a přetáhneme nahoru (nebo dolů) na lištu > okno se tam 
uchytí. Z lišty do pracovní plochy lze toolbar opět přetáhnout po zachycení myší za jeho okraj. 
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Vytváření datových spojů do obrázků (data links) 

Klikneme na tlačítko Data Link Stamper     v okně DeltaV_Toolbox > objeví se okno 
Datalink (obr.17) 
 

 
 

Obr.17 Okno Datalink 
 

Klikneme na tlačítko   v okně Datalink > objeví se okno Expression Builder > vybereme 
kartu FIX Database a vybereme THISNODE v okně Node Names > otevřeme kartu DeltaV a 
klikneme na Browse Delta V Control Parameters > otevře se okno Browse > dvojklik na 
AREA101_vasejmeno > objeví se okno (obr.18). 
 
Dvojklik na jméno modulu LI-101_vasejmeno > objeví se seznam jeho funkčních bloků a 
parametrů modulu > dvojklik na funkční blok AI1 > objeví se parametry tohoto funkčního 
bloku > dvojklik na parametr PV  (process value) > objeví se seznam polí > klikneme na pole 
CV (current value) > OK > OK v okně Expression Builder. 
 
Vrátíme se do okna Datalink > v poli Source se objevil  
datový spoj udávající výšku hladiny v nádrži: DVSYS.LI-101_vasejmeno/AI1/PV.F_CV > 
v poli Type volíme Numeric > Whole Digits > 5 > Decimal > 2 > v poli Data Entry Type 
volíme None (operator nemůže změnit) > klikneme OK. 
 
Objeví se hlášení že zdroj neexistuje (na cvičném počítači není připojen systém) > klikneme 
na Use Anyway > na obrázku TANK101.grf se objevil symbol razítka se zvoleným formátem 
#####.## > umístíme tento symbol do levého horního kvadrantu a klikneme na něj > kliknutím 
na nástroj textu  napíšeme LI-101/PV > z textového režimu vystoupíme kliknutím mimo 
prostor textu. 
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Obr.18 Okno pro vytváření datových spojů (do pozice vasejmeno je použito MIRDA) 
 

Podobně vytvoříme  
DVSYS.FIC-101/PID1/SP.F_CV       nastavení požadované hodnoty (set point) - (pole Data 
Entry Type volíme In-Place – operátor může hodnotu změnit) 
 
DVSYS.FIC-101/PID1/PV.F_CV       hodnota  měřeného průtoku (process value) - (pole Data 
Entry Type volíme None – operátor nemůže hodnotu změnit) 
 
DVSYS.FIC-101/PID1/OUT.F_CV    nastavení polohy ventilu operátorem (pole Data Entry                

Type volíme In-Place) > klikneme na DeltaV Data Entry  
na kartě Numeric Alfa ověříme volbu Numeric Entry a zaškrtnutí Fetch Limits from the Data 
Source > OK 

 
DVSYS.MTR-101/DC1/SP_D.A_CV  (písmeno A značí ovládání motoru operátorem v ASCII -
- START, STOP) 

(pole Data Entry Type volíme None) > klikneme na   > karta PushButton > do pole Open 
Button Title(0) napíšeme STOP > do pole Close Button Title(1) napíšeme START > OK 
 
Ke všem zdrojům dat dopíšeme text podle obr.22. 
 
 
Dále vytvoříme aktivní obrázek (dynamo) 
Otevřeme v adresáři vlevo Dynamo Sets > dvojklik na Pumps Anim > vybereme 
PumpsAnimVertA1 a přetáhneme do obrázku > v okně Pump Dynamo zaškrtneme Animate  
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Pump Color > OK > okno upravíme podle obr. 19. > OK > objeví se hlášení: The Data Source 
does not exit. Do you want to use it anyway? > klikneme Yes > OK v okně Pump Dynamo 
Zavřeme Pumps Anim. 
 

 
 

Obr.19 Okno pro nastavení barev animace čerpadla 
 
Dvojklik na TanksAnim1 > vybereme a přetáhneme do obrázku nad čerpadlo > objeví se okno, 
které upravíme podle obr.20 > zaškrtneme Fetch Limits from Data Source > OK > Use it 
anyway? Yes > zavřeme TanksAnim1 
  
Z nabídky Pipes doplníme potrubí. 
 
Z nabídky ValvesAnim doplníme ventil ValveHorizAnim1 > postupem jako v předchozích 
případech doplníme cestu k parametru pro referenci dynamických vlastností a to podle obr.20 
> pozor okno se po OK  nechce zavřít ( dát Close) – sledovat tento jev při dalších pokusech. 
 
Z nabídky ValvesAnim doplníme ValveHorizontalControl1 > v okně nastavíme animaci 0-50 
červená, 50-100 zelená > cesta k referenci animace FIC-101/PID1/PV 
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Obr.20 Okno pro animaci nádrže 
 
 

 
 

Obr.21 Okno pro nastavení animace ventilu 
 

Přidáme zapisovač se třemi pery. 

Klikneme na Chart  a v obrázku obtáhneme obdélník > objeví se graf > pravým tlačítkem 
do grafu a z nabídky vybereme Chart Configuration… > karta Chart > do pole Pen List a 

smažeme tam zapsanou cestu > klikneme na Add Pen  a potom na   > pomocí již 
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známého Expression Builder zapíšeme do okna Pen List cesty podle obr.22 > klikneme na Y-
Axis a změníme název osy na Flow > zaškrtneme Apply To All Pens > klikneme na X-Axis a 
změníme název na Time > OK > ještě jednou OK. 
 
 

 
 

Obr.22 Okno pro nastavení zapisovače 
 

 
Do obrázku ještě přidáme tlačítko pro spuštění SFC 
Klikneme na Insert > Push Button > tlačítko umístíme v obrázku > klikneme na  a 
napíšeme na tlačítko Start Discharge. 
 
Vybereme tlačítko > klikneme na Task Wizard    (toolbox DeltaV Standard) > otevře se 
okno The Task Wizard > v poli Task Categories vybereme Command > v poli Tasks vybereme 
Write Value to Tag Expert > klikneme na tlačítko Perform Task > otevře se okno Write A  
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Value Expert > pomocí průvodce Expression Builder vyplníme okno podle obr.23 ( 1 v poli 
Value určuje dříve definovanou hodnotu START pro SFC) > OK > Close okno The Tank 
Wizard > uložíme TANK101 (obr.24) > zavřeme TANK101. 
 
 
 

 
 

Obr.23 Okno pro nastavení funkce tlačítka 
 
 

 
 

Obr.24 Konečný vzhled obrázku TANK101 
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Práce programu DeltaV Operate v režimu Run 
Klikneme na Workspace > Switch to Run  nebo Ctrl/W. 

Klikneme na  Open Main Display  a z nabídky Replace Main Picture vybereme TANK101 
> Enter > objeví se připravený obrázek TANK101 (místo čísel jsou hvězdičky). 
 
  
 


